Skip to content
WJunction - Webmaster Forum

Bigdump

Status
Not open for further replies.
i am trying to import a database which i have moved from one host to another but i get this error while using bigdump

Stopped at the line 2626.
At this place the current query includes more than 300 dump lines. That can happen if your dump file was created by some tool which doesn't place a semicolon followed by a linebreak at the end of each query, or if your dump contains extended inserts. Please read the BigDump FAQs for more infos.
Stopped on error




how can i get round this the old server is now offline ? :(


any other tools please
 

23 comments

You can also ask your host, or, if you have ssh access, to load the sql dump file in through ssh. Doing so through ssh is much faster, and can handle very large databases.

Code:
mysql -u username -p -D databasename < dumptextfile.sql

This will ask you for the database password when run. Of course, you must fill in the correct information above.
 
MySQL says:
Variable 'character_set_client' can't be set to the value of 'NULL'
Error in Query:
SET character_set_client = @saved_cs_client;

with mysqldumper
 
i am trying to import a database which i have moved from one host to another but i get this error while using bigdump

Stopped at the line 2626.
At this place the current query includes more than 300 dump lines. That can happen if your dump file was created by some tool which doesn't place a semicolon followed by a linebreak at the end of each query, or if your dump contains extended inserts. Please read the BigDump FAQs for more infos.
Stopped on error




how can i get round this the old server is now offline ? :(


any other tools please

Open up bigdump.php and look for the following
Code:
define ('MAX_QUERY_LINES',300);      // How many lines may be considered to be one query (except text lines)

Replace 300 with a higher number.
 
tried that and got this lol

Error at the line 3011: SET character_set_client = @saved_cs_client;
Query: SET character_set_client = @saved_cs_client;
MySQL: Variable 'character_set_client' can't be set to the value of 'NULL'
Stopped on error

gets better
 
Status
Not open for further replies.

About the author

L
Active Member · Joined
669
Messages
1
Reactions
18
Points

Advertise on WJunction

Reach 1000's of webmasters, hosts & affiliates. Banner & sponsored-thread slots available.

Contact us
Back
Top Bottom